cmp.is

Install Python 3.5 on Ubuntu Trusty 14.04 LTS

0 Comments

Fixing a server today and had to figure out a better way to install Python 3.5.

The server lost it’s init because we added py35 by adding Wily’s repos which then screwed up all the updates for the system. Then we couldn’t restart/shutdown/boot.

I forget why we did that, but it’s probably cause it wasn’t known this other PPA existed to avoid this problem

ppa:fkrull/deadsnakes supports just about any Python version you need (including 3.5) for Precise, Trusty, and Wily.

To use:

$ sudo add-apt-repository ppa:fkrull/deadsnakes

Any issues or suggestions? Tell me on github.

0 Comments